Announcement Announcement Module
Collapse

myhosting.com Forum Guidelines

Welcome to the myhosting.com Forums! The purpose of this forum is to allow you to discuss topics relating to hosting and topics of interest with other myhosting.com Customers. The primary focus should relate to issues not generally included in our Wiki or Control Panel, or information not provided by our Customer Support Team. Some examples include programming and coding support, web site design ideas and SEO practices.

The forum is not meant as a replacement to our Wiki or Customer Support. We highly recommend searching our Wiki before posting on the forum. Also, if you have a question for our Customer Support team, please contact them as you would normally.

We ask that if you have any complaints or questions relating specifically to your account, that you address them to our Customer Support department. Do not post personal account information such as passwords or other sensitive and private information the forum, as this type of information is best kept secret. Also, please be respectful of other users and refrain from defamatory comments or use of coarse language.

We will visit the forum from time to time, and contribute to various topics. We reserve the right to delete any posts which are deemed offensive or against the spirit of the forum. Any spamming or illegal activity will not be tolerated. We also reserve the right to block any user who violates these guidelines.

To get started, we welcome you to sign up at our User Management site. Any account created there will have access to these forums, our Wiki, our Ideas site and commenting permission on our Status Blog.
See more
See less
HELP! my .htaccess and .htpasswd doesn't work Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • HELP! my .htaccess and .htpasswd doesn't work

    Hi folks,
    I've uploaded both files to my folder under /docs/mystuff
    I get the pop up window asking for authentication.
    but i authenticate and I get pop up over and over again

    here are what the files look like...

    .HTACCESS
    AuthType Basic
    AuthName "Members Only"
    AuthUserFile /var/www/domains/mydomain.com/docs/mystuff/.htpasswd
    <limit GET PUT POST>
    require valid-user
    </limit>

    .HTPASSWD
    username:$1$blahblahstringoflettesandnumbers/ <<this is the MD5 one whatever that means

    Do i need the DES encrypted one as well? or just one? and if so, which one?

    Any help is appreciated.
    Thanks in Advance

    ps. i have kept the file names in lowercase.
    i have removed the .txt windows creates
    I have uploaded in both binary and ascii both to no avail
    i have uploaded the htpasswd to both /mystuff folder and in /docs folder (btw which is proper location?)

  • #2
    Re: HELP! my .htaccess and .htpasswd doesn't work

    Hi There,

    I just tried this and it works for me, you can use DES or md5, I don't think it matters. But one thing I noticed is that the Wiki article shows a "/" at the end of each line in the .htpasswd file, which I believe is incorrect.

    Try removing the / from the end of those usernameassword lines, and let us know if that fixes the problem.

    Thanks,

    Comment


    • #3
      Re: HELP! my .htaccess and .htpasswd doesn't work

      Hi Tima,
      Thanks. I tried removing the / but still no access. I am getting prompted though still.
      what should the chmod setting for this folder be?

      Comment


      • #4
        Re: HELP! my .htaccess and .htpasswd doesn't work

        I don't think the chmod matters, I didn't modify it from default in my test. You could try re-generating the passwords again, just to make sure there was no copy/paste error. Since they are encrypted its hard to check this easily.

        Comment

        Working...
        X