Announcement Announcement Module
Collapse

myhosting.com Forum Guidelines

Welcome to the myhosting.com Forums! The purpose of this forum is to allow you to discuss topics relating to hosting and topics of interest with other myhosting.com Customers. The primary focus should relate to issues not generally included in our Wiki or Control Panel, or information not provided by our Customer Support Team. Some examples include programming and coding support, web site design ideas and SEO practices.

The forum is not meant as a replacement to our Wiki or Customer Support. We highly recommend searching our Wiki before posting on the forum. Also, if you have a question for our Customer Support team, please contact them as you would normally.

We ask that if you have any complaints or questions relating specifically to your account, that you address them to our Customer Support department. Do not post personal account information such as passwords or other sensitive and private information the forum, as this type of information is best kept secret. Also, please be respectful of other users and refrain from defamatory comments or use of coarse language.

We will visit the forum from time to time, and contribute to various topics. We reserve the right to delete any posts which are deemed offensive or against the spirit of the forum. Any spamming or illegal activity will not be tolerated. We also reserve the right to block any user who violates these guidelines.

To get started, we welcome you to sign up at our User Management site. Any account created there will have access to these forums, our Wiki, our Ideas site and commenting permission on our Status Blog.
See more
See less
MyHosting Cubecart Mail() SMTP auto email not working Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • MyHosting Cubecart Mail() SMTP auto email not working

    Regarding CUBECART built-in mail function. This has been an issue for YEARS...

    I found the solution to the issue and appearantly it is only with myhosting.com servers. So if someone has an account with myhosting, they will NOT be able to use their mail() function or smtp function to send mail through myhosting.com's servers. I will attach the smtp file (fix) I am using with one line of minor modification for anyone else who may run into this problem who is using myhosting.com services. This is a fix for v3 and v4.

    Basically, you can only use mail option SMTP with myhosting.com with this edited version of the SMTP file included. The basic installation smtp file will NOT WORK- It must be modified for the automatic mail function to work. You must use smtp mail setting under general settings, select "yes" user requires authentication and put in the credentials for admin@whateverdomain.com

    I had a lot of trouble with this and previous versions... I hope this can help other people who run into a similar situation.

    Solution Replace the file under WebRoot\classes\smpt.php for Version 3
    Webroot\classes\htmlMimeMail\smtp.php Version 4

  • #2
    Re: MyHosting Cubecart Mail() SMTP auto email not working

    Thanks for sharing liquidwebco!

    Comment


    • #3
      Re: MyHosting Cubecart Mail() SMTP auto email not working

      the smtp.php file is corrupt and throws a fatal error on the server, anyone have a good version of the fixed smtp.php file, ppppleassse

      Comment


      • #4
        Re: MyHosting Cubecart Mail() SMTP auto email not working

        I figured it out! For those of you receiving file.php (I'm on a mac) download linked file as smtp.zip then unzip it. I was getting file.php, change it to smtp.zip before downloading it, then all will go as planned! :lol:

        Comment


        • #5
          Re: MyHosting Cubecart Mail() SMTP auto email not working

          and now my email in CC WORKS!!!!! YAY!!!!!

          Comment


          • #6
            Re: MyHosting Cubecart Mail() SMTP auto email not working

            I have forwarded this problem and fix to CubeCart. They are fixing this issue in the next release!

            Comment


            • #7
              Thanks for the information. It was able to learn something effective and I hope you could me and others with other future script problems. Thanks again!

              Comment


              • #8
                Originally posted by liquidwebco View Post
                Regarding CUBECART built-in mail function. This has been an issue for YEARS...

                I found the solution to the issue and appearantly it is only with myhosting.com servers. So if someone has an account with myhosting, they will NOT be able to use their mail() function or smtp function to send mail through myhosting.com's servers. I will attach the smtp file (fix) I am using with one line of minor modification for anyone else who may run into this problem who is using myhosting.com services. This is a fix for v3 and v4.

                Basically, you can only use mail option SMTP with myhosting.com with this edited version of the SMTP file included. The basic installation smtp file will NOT WORK- It must be modified for the automatic mail function to work. You must use smtp mail setting under general settings, select "yes" user requires authentication and put in the credentials for admin@whateverdomain.com

                I had a lot of trouble with this and previous versions... I hope this can help other people who run into a similar situation.

                Solution Replace the file under WebRoot\classes\smpt.php for Version 3
                Webroot\classes\htmlMimeMail\smtp.php Version 4

                Call me confused... But I don't know where to download the file you are referring to. Where is it downloadable from?

                Comment


                • #9
                  smtp.php file

                  I've attached the original file from this post, in case anyone is looking for it. You'll need to change the filename from smtp.txt to smtp.php.

                  Comment


                  • #10
                    updated smtp.php

                    We did some more investigation and found that it works much better with the following line removed:

                    Code:
                    if (!defined('CC_INI_SET')) die("Access Denied");
                    Attached is the most up-to-date version.

                    Comment


                    • #11
                      Tima,

                      I was just coming to re-attach this same file and you beat me to it

                      Thank you guys so much for helping me with this issue.

                      For those looking for the answer, this works! The edited SMTP file appears to be working for my tests.

                      With this solution I can now:

                      - SEND TEST ENEWSLETTERS (havent yet tried sending a 'real' enewsletter to customers but I have no reason to believe it doesnt work)
                      - SEND FORGOT PASSWORDS EMAIL to CUSTOMERS
                      - SEND PURCHASE CONFIRMATION TO ADMIN & CUSTOMER


                      Thanks again!!

                      Comment

                      Working...
                      X