Announcement Announcement Module
Collapse

myhosting.com Forum Guidelines

Welcome to the myhosting.com Forums! The purpose of this forum is to allow you to discuss topics relating to hosting and topics of interest with other myhosting.com Customers. The primary focus should relate to issues not generally included in our Wiki or Control Panel, or information not provided by our Customer Support Team. Some examples include programming and coding support, web site design ideas and SEO practices.

The forum is not meant as a replacement to our Wiki or Customer Support. We highly recommend searching our Wiki before posting on the forum. Also, if you have a question for our Customer Support team, please contact them as you would normally.

We ask that if you have any complaints or questions relating specifically to your account, that you address them to our Customer Support department. Do not post personal account information such as passwords or other sensitive and private information the forum, as this type of information is best kept secret. Also, please be respectful of other users and refrain from defamatory comments or use of coarse language.

We will visit the forum from time to time, and contribute to various topics. We reserve the right to delete any posts which are deemed offensive or against the spirit of the forum. Any spamming or illegal activity will not be tolerated. We also reserve the right to block any user who violates these guidelines.

To get started, we welcome you to sign up at our User Management site. Any account created there will have access to these forums, our Wiki, our Ideas site and commenting permission on our Status Blog.
See more
See less
Wordpress - Permissions problems Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wordpress - Permissions problems

    Hello!

    I'm having some issues with all of our Wordpress installations on our Myhosting.com Linux sub-site and they all have to do with not having sufficient permissions.

    WP's auto-update, in addition to some of the plugins (a csv importer), will not function. The plugin, specifically, is the main issue. I am confronted with the following error:

    Warning: move_uploaded_file(/var/www/domains/ourdomain.com/docs/temp-file.csv) [function.move-uploaded-file]: failed to open stream: Permission denied in /var/www/domains/ourdomain.com/docs/subdir/wp-content/plugins/store-locator/add-locations.php on line 51

    I have attempted to change the permissions to the file in question by way of my ftp client and the myhosting.com file manager... to no success (changed to 775 from 644).

    Any help would be much appreciated!

  • #2
    Setting the permissions to 777 during your upgrade should work, just be sure to set them back after. I imagine the same would apply to the CSV import plugin.

    Comment


    • #3
      Hi Ian. It's strange that WordPress' auto-upgrade tool doesn't work for you. I just tried it in a fresh WordPress install on a test domain, and the upgrade succeeded.

      In your WordPress admin control panel, when you go to
      Tools > Upgrade > Upgrade Automatically
      are you asked to fill in "connection information"?

      For the plugin that's failing to move a file, you'll probably need to set the permissions on files and directories in wp-content/uploads/ to 777.

      Let me know about the upgrade tool and if the 777 perm works. Cheers,
      Nick

      Comment


      • #4
        Hi Jeremy and Nick, thanks for replying.

        Setting the permissions to 777 during your upgrade should work, just be sure to set them back after. I imagine the same would apply to the CSV import plugin.
        For the plugin that's failing to move a file, you'll probably need to set the permissions on files and directories in wp-content/uploads/ to 777.
        Unfortunately, there is no uploads directory in /wp-content. However, there is one at wp-content/plugins/store-locator/uploads. I've tried setting this folder to 777, in addition to the add-locations.php file in the warning. Doing this didn't work out.

        Are there specific Wordpress files that should have changed permissions, as a foundation (before any plugins come into play), because in addition to the plugin problem, I do not have access to the theme/plugin editors in WP.

        In your WordPress admin control panel, when you go to
        Tools > Upgrade > Upgrade Automatically
        are you asked to fill in "connection information"?
        Yep. I've tried putting in the information I use for FTP access (IP address, ftp username/password) and the updater did not work.

        The error I receive is:

        Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/tmp//wordpress-2.8.5.zip) is not within the allowed path(s): (/var/www/domains/ourdomain.com/:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/www/myfilemanager:/var/www/myinstaller:/usr/local/lib/php) in /var/www/domains/ourdomain.com/docs/locate/wp-includes/functions.php on line 2118

        Warning: touch() [function.touch]: open_basedir restriction in effect. File(/tmp/wordpress-2.8.5.zip) is not within the allowed path(s): (/var/www/domains/ourdomain.com/:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/www/myfilemanager:/var/www/myinstaller:/usr/local/lib/php) in /var/www/domains/ourdomain.com/docs/locate/wp-admin/includes/file.php on line 175

        Download failed.: Could not create Temporary file

        Installation Failed
        Last edited by ian; 2009-10-22, 08:03 PM. Reason: added warnings from Wordpress auto-updater

        Comment


        • #5
          Originally posted by ian View Post
          Unfortunately, there is no uploads directory in /wp-content.
          Hrm, you should really have that. Create wp-content/uploads/ , and set the permissions on it to 777.

          Originally posted by ian View Post
          I've tried setting this folder to 777, in addition to the add-locations.php file in the warning. Doing this didn't work out.
          Restore the original perms on add-locations.php . 777 on it won't help, because that simply allows anyone to read, edit, and execute that PHP script.

          Originally posted by ian View Post
          Yep. I've tried putting in the information I use for FTP access (IP address, ftp username/password) and the updater did not work.

          The error I receive is:

          Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/tmp//wordpress-2.8.5.zip) is not within the allowed path(s): (/var/www/domains/ourdomain.com/:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/www/myfilemanager:/var/www/myinstaller:/usr/local/lib/php) in /var/www/domains/ourdomain.com/docs/locate/wp-includes/functions.php on line 2118
          Could you please post which domain you're having troubles with, or PM it to me? This error shouldn't be happening, so I'd like to check what's causing it on your server.

          Comment


          • #6
            Hrm, you should really have that. Create wp-content/uploads/ , and set the permissions on it to 777.
            Ok, done.

            Restore the original perms on add-locations.php . 777 on it won't help, because that simply allows anyone to read, edit, and execute that PHP script.
            Yep, done.

            Could you please post which domain you're having troubles with, or PM it to me? This error shouldn't be happening, so I'd like to check what's causing it on your server.
            There are particulars to how it's all setup, which I'd rather PM you. But, I can't seem to find the PM link. It's not in your drop-down menu and it's not in the UCP.
            Last edited by ian; 2009-10-23, 03:19 PM.

            Comment


            • #7
              Originally posted by ian View Post
              eco-max.ca (there are particulars to how it's all setup, which I'd rather PM you. But, I can't seem to find the PM link. It's not in your drop-down menu and it's not in the UCP.)
              That's odd. I'll send you a PM, and then you can reply to it.

              Comment


              • #8
                From the PHP error that I have read, it seems creating the "uploads" folder and setting it to 777 should fix the problem.

                Comment


                • #9
                  Originally posted by RichardLeik View Post
                  From the PHP error that I have read, it seems creating the "uploads" folder and setting it to 777 should fix the problem.
                  Thanks for the recommendation, Richard. That wasn't the issue, but we fixed the problem via PM on Friday afternoon.

                  Comment


                  • #10
                    Originally posted by nickh View Post
                    Thanks for the recommendation, Richard. That wasn't the issue, but we fixed the problem via PM on Friday afternoon.
                    I'm having the same problem..

                    I'm pretty sure it has to do with my installation.. I brought my wordpress from another host.. didn't not used your installer..

                    I'm almost certain the problem is with the owner of the files and the account running apache!!

                    Can you help? domain is cachedisland.com..

                    Comment


                    • #11
                      did you chmod 777 to "upload" folder?

                      http://www.imgsnatch.com/img/n/9.jpg

                      Comment


                      • #12
                        Originally posted by greenmatter View Post
                        did you chmod 777 to "upload" folder?

                        http://www.imgsnatch.com/img/n/9.jpg
                        yes I did.. altough I shouldn't have to do it if the owner corresponds to the account running httpd


                        On my previous host all folders where 755 and all files 644 and it worked fine.

                        This page explains the problem but I can't do it since I don't have ssh access.. all I need is this done only to my httpdocs folder..

                        http://robspencer.net/auto-update-wo...s-without-ftp/

                        Comment


                        • #13
                          Hi jaas666,

                          On our new onCloud platform, SSH is allowed but you have to contact our Customer Support team to activate it. On the previous myhosting.com "Classic" platform, we do not support SSH.
                          You can shoot PM to nickh who solved this problem or Contact customer support 24/7 In-House Phone Support | myhosting.com

                          Cheers

                          Comment


                          • #14
                            Originally posted by suwunk View Post
                            Hi jaas666,


                            You can shoot PM to nickh who solved this problem or Contact customer support 24/7 In-House Phone Support | myhosting.com

                            Cheers

                            Can't find the PM button... and already wrote yesterday to support but haven't gotten a response yet.

                            Comment


                            • #15
                              Originally posted by suwunk View Post
                              Hi jaas666,


                              You can shoot PM to nickh who solved this problem or Contact customer support 24/7 In-House Phone Support | myhosting.com

                              Cheers
                              Thanks for the info.. I really don't need SSH as I'm not a linux guy.. propably will make it worse..

                              I preffer if someone with the knowledge (myhosting.com support staff?) can do it for me.

                              I searched for a PM link to contact nickh but couldn't find any.. I also contacted support via email yesterday but haven't heard from them.

                              Comment

                              Working...
                              X