Announcement Announcement Module
Collapse

myhosting.com Forum Guidelines

Welcome to the myhosting.com Forums! The purpose of this forum is to allow you to discuss topics relating to hosting and topics of interest with other myhosting.com Customers. The primary focus should relate to issues not generally included in our Wiki or Control Panel, or information not provided by our Customer Support Team. Some examples include programming and coding support, web site design ideas and SEO practices.

The forum is not meant as a replacement to our Wiki or Customer Support. We highly recommend searching our Wiki before posting on the forum. Also, if you have a question for our Customer Support team, please contact them as you would normally.

We ask that if you have any complaints or questions relating specifically to your account, that you address them to our Customer Support department. Do not post personal account information such as passwords or other sensitive and private information the forum, as this type of information is best kept secret. Also, please be respectful of other users and refrain from defamatory comments or use of coarse language.

We will visit the forum from time to time, and contribute to various topics. We reserve the right to delete any posts which are deemed offensive or against the spirit of the forum. Any spamming or illegal activity will not be tolerated. We also reserve the right to block any user who violates these guidelines.

To get started, we welcome you to sign up at our User Management site. Any account created there will have access to these forums, our Wiki, our Ideas site and commenting permission on our Status Blog.
See more
See less
My Wordpress can send mail in MyHosting Classic, but not in MyHosting Cloud Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • My Wordpress can send mail in MyHosting Classic, but not in MyHosting Cloud

    I was running some wordpress installarions in MyHosting classic linux hosting, and everything was working fine, my Wordpress could send e-mails to me when I received comments, posts, backup, etc.

    Now I migrated to MyHosting Cloud and many things just stopped to work.

    1st at all I was forced to set "define('WP_MEMORY_LIMIT', '64M');" on Wordpress config file, cause the WP-Admin page returned many of errors about memory on default memory use (32mb)

    2nd problem is about these e-mails, after the migration I just can't receive nothing, comments, posts backup, nothing, Wordpress don't return any error, I don't know what can I do to allow my application to send e-mails to me.

    3rd thing... someone haves any php send mail to me? On MyHosting wiki haves only an ASP example, but I use as primary hosting an Apache server ^^

    Tyvm all

    plz help me /o\

  • #2
    "Classic" and "Cloud"

    Doomer,

    What are "MyHosting classic linux hosting" and "MyHosting Cloud"? I haven't heard of either.

    Thanks,
    Shane.

    Comment


    • #3
      Hey Guys - thanks for the comments and questions.

      For the technical issues - I suggest chatting with our CS superstars.
      1 (866) 289-5091 > and they'll honestly be on the phone with you in moments!

      As for the myhosting classic vs cloud > we recently changed our control panel, which all new clients are being set up on. We're looking to migrate - hopefully soon all clients will be on cloud - until then, we're operating on both platforms.

      Hope that helps!

      Cheers,
      Mels

      Comment


      • #4
        lol tyvm

        I sent a mail to service desk and suddenly my new hosting started to send messages =)

        Comment


        • #5
          This problem persists

          I receive some messages, and lot another just does not comes to my inbox.

          I suppose that this mail() php function is very unstable or with any insane spam protection, my application receives the info that its successfull sent but your SMTP just don't deliver the message to my MX. And I didn't got these problems on myhosting "classic" version.

          PS: My e-mail is hosted in Mail2Web professional exchange service and MyHosting servers is already listed on my whitelist.

          If someone knows a workaround, I appreciate it.

          Tyvm

          ps: I already tried to use an SMTP sender but MyHosting does not allow PHP apps to connect.
          "SMTP connection failed to start [tls://ex7.mail2web.com:21]: fsockopen returned Error Number 111 and Error String 'Connection refused''
          Last edited by Doomer; 2010-03-17, 06:10 PM.

          Comment


          • #6
            filters

            It's always a good idea to check your e-mail filters and spam filters as well.

            Comment


            • #7
              Originally posted by Not2BigNot2Small View Post
              It's always a good idea to check your e-mail filters and spam filters as well.
              already double checked and tested with another mail servers too
              nothing works fine =/

              edit: i did a simple test right now:
              I sent a contact form to icarlos@icarlos.net (my email in mail2web) and received.
              I sent a second contact form to icarlos@g.icarlos.net (hosted in google apps) and DON'T received.
              I sent a third contact form back to icarlos@icarlos.net (in mail2web) and DON'T received!

              It's clear that it's an inconstant, unstable or badly configured smtp service used by php mail() messages, cause in all times the php mail() function returns that the message was successfully sent.

              *yes, i'm already talking with support, but they don't read my question and still asking about things that does not apply to the case.
              Last edited by Doomer; 2010-03-17, 07:55 PM.

              Comment


              • #8
                when sending from your onCloud account I believe you need to ensure you're connecting to the proper sending hostname. In onCloud if you're on a windows server you need to specify send.winweb.myhosting.com as the sending server. If you're on a linux server you should be able to use localhost.

                Hope that helps!

                Comment


                • #9
                  Originally posted by jeremya View Post
                  when sending from your onCloud account I believe you need to ensure you're connecting to the proper sending hostname. In onCloud if you're on a windows server you need to specify send.winweb.myhosting.com as the sending server. If you're on a linux server you should be able to use localhost.

                  Hope that helps!
                  I'm just using a mail() function, where can I set the hostname in a php native function? I don't have access to php.ini settings...

                  Comment

                  Working...
                  X