Announcement Announcement Module
Collapse

myhosting.com Forum Guidelines

Welcome to the myhosting.com Forums! The purpose of this forum is to allow you to discuss topics relating to hosting and topics of interest with other myhosting.com Customers. The primary focus should relate to issues not generally included in our Wiki or Control Panel, or information not provided by our Customer Support Team. Some examples include programming and coding support, web site design ideas and SEO practices.

The forum is not meant as a replacement to our Wiki or Customer Support. We highly recommend searching our Wiki before posting on the forum. Also, if you have a question for our Customer Support team, please contact them as you would normally.

We ask that if you have any complaints or questions relating specifically to your account, that you address them to our Customer Support department. Do not post personal account information such as passwords or other sensitive and private information the forum, as this type of information is best kept secret. Also, please be respectful of other users and refrain from defamatory comments or use of coarse language.

We will visit the forum from time to time, and contribute to various topics. We reserve the right to delete any posts which are deemed offensive or against the spirit of the forum. Any spamming or illegal activity will not be tolerated. We also reserve the right to block any user who violates these guidelines.

To get started, we welcome you to sign up at our User Management site. Any account created there will have access to these forums, our Wiki, our Ideas site and commenting permission on our Status Blog.
See more
See less
How do you increase PHP Memory Limit? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • How do you increase PHP Memory Limit?

    The current php memory limit of 41943040 bytes is too small as I am hitting the wall with Drupal. Their recommendation is 64M but they would even prefer 128M. I have tried to set this though the .htaccess file in my root drupal folder to no avail.

    Is there a way I can do this or do I need myhosting tech to increase it for me?

    I did find another .htaccess file in the webspace folder, but it is locked. I couldn't locate a php.ini file to edit the setting either.

  • #2
    Hi There,


    Which hosting plan do you have? File Manager and FTP doesn't allow you to access php.ini

    If you use VPS, You can try this.
    SSH into your server
    Log in as root.
    Type the following and hit enter: vi /usr/local/lib/php.ini
    Now that you’re in vi
    Press the “i” key. This puts you in “insert” mode, which basically
    allows you to edit things.
    when you`ve done with modification
    Press escape, then type :wq and hit enter. That says “save the file
    and quit.”

    If You`re in shared hosting, You should ask customer care to increase memory limit.
    You can also try this module Drupal tweaks | drupal.org

    Cheers

    Comment


    • #3
      could you give it a shot now and let me know if you're still having trouble?

      Comment


      • #4
        I'm in shared hosting and don't have access to SSH. I will try sending a ticket. Wow, though, thanks for the quick response!!
        (^_^)

        Comment


        • #5
          Also, it doesn't look like Drupal Tweaks has a Drupal 7 version, but thanks!

          Comment

          Working...
          X